Outlook 2016 Not Connecting to Exchange+ Hosted Mailbox

Description

We have had reports of Outlook 2016 profiles having problems. As far as we can tell, there may have been an update to Outlook 2016 that is causing strange Autodiscover behavior. In some cases, the profile no longer connects to Mailprotector's Exchange+ servers but an outlook.com address.

Applies to:

Exchange+, Outlook 2016

Workaround Options

We have been directing partners to review the following KB article:

Unexpected Autodiscover Behavior When Registry Settings are Changed

That article references the Microsoft document found at:

https://support.microsoft.com/en-us/help/2212902/unexpected-autodiscover-behavior-when-you-have-registry-settings-under

  • We typically recommend adding the ExcludeExplicitO365Endpoint and ExcludeHttpsRootDomain DWORDs with a value of 1 to the registry.
  • Run the Windows Update process to make sure Outlook doesn't need another update.
  • Check the Windows Credentials Manager and delete all entries that pertain to Outlook and the email accounts.
  • Then, create a new profile and see if that resolves the issue.

Using Outlook Web App (OWA) to confirm the correct mailbox password is a good idea and a workaround for the user until the Outlook problem can be resolved. Unfortunately, this is not a server-related issue that we can fix. It is a client-side Autodiscover problem that has some variability in the reports we have received.

Registry File for Import

For convenience, the registry file below can be downloaded and imported into a workstation's registry. The values provide the settings recommended in the workaround above as well as additional DWORD values to exclude local Autodiscover responses and help the workstation reach the SRV record for Mailprotector's Exchange+ hosted mailboxes.

Have more questions? Submit a request

Comments