ForcEncrypt V1 - Minimum System Requirements

What are the minimum system requirements?

Once you are set up with a Secure Messaging account, there are a number of ways that you can access it. This includes on the web using the webapp or by adding Secure Messaging to your preferred email client, such as Outlook, Office 365 OWA, or Gmail.

Below are the current minimum system requirements to access your Secure Messaging account:

Web browsers:

  • Firefox 33.0+
  • Microsoft Internet Explorer 10+ with TLS 1.0+ enabled
  • Safari 5.1.7+
  • Chrome 39.0+

Secure Messaging Outlook add-in:

  • Microsoft Windows 7/8/10+
  • MS .NET Framework 4.0+ (installed automatically)
  • Microsoft Office 2007, 2010, 2013 and 2016 / Office 365 with the latest service packs installed.

Secure Messaging Google Chrome extension:

  • Chrome 39.0+

Secure Messaging Mac app:

  • Yosemite+

Secure Messaging Office 365 OWA add-in:

  • Microsoft Internet Explorer 10+ with TLS 1.0 enabled

Secure Messaging for mobile:

  • iOS: 9.0+
  • Android: 4+
  • Windows phone: 8+
  • Blackberry: 10+
Have more questions? Submit a request

Comments